Hide the left page number display

Is there any default option that allows me to hide the left page number display on the screen? Users who want to view the entire document content without the distraction of the page numbers on the left side can choose this secondary option.


Yes, there is a property to handle the visibility of this component. Depending on whether you are using .NET Framework or .NET Core, you should assign the change as follows:

For .NET Framework, you need to add the ShowToolTip property to the instance of the DocViewer object in the .cs file:

var viewer = new DocViewer
    ShowToolTip = false, 

For .NET Core, you should set the value of the showToolTip in the docViewer function in JavaScript:

objctlDoc = $("#div_ctlDoc").docViewer(
        showToolTip: false,

If you have any further questions about the document viewer, feel free to ask!

I followed your instructions, but it seems not to be working as I intended. I want the default interface screen to appear when entering the page, and there should be no pagination screen like in Figure 2.

1.PNG (140.6 KB)

2.PNG (116.5 KB)


I would like additional details about the application to provide more effective assistance.

Are .NET Framework or .NET Core being used? Furthermore, if a small project or code snippet that sets the value of the ShowToolTip property could be attached, it would greatly aid in understanding the context and offering a more precise solution.

Thank you for your help.

1 Like

I appreciate you responding to me.
The project I’m working on .Net Core. Here is a snippet of code from the project where I’m using the showToolTip property.

z4907262314985_928fd82e6a78917620c812012b700324.jpg (130.1 KB)


The code looks perfect.

The issue may be related to browser caching. To check this problem, I suggest the following options:

  • Clear browser cache
  • Try in an incognito window or another browser

Let me know if the problem with the viewer was resolved after these tests.

After following your instructions clear cache and set the value of the ‘showToolTip’ field to ‘false,’
I still cannot close the displayed page section. Perhaps I will suggest users manually close it.
Thank you for your support throughout this time.
Capture4.PNG (155.9 KB)

Additional: Is there any Doconut attribute related to the ctlDoc_splitter property?


To close the view of document thumbnails, you must set the showThumbs property to false.

objctlDoc = $("#div_ctlDoc").docViewer(
         showThumbs: false,

You can also use the HideThumbs function, to set the property to, for example, a link or button:

<a onclick="objctlDoc.HideThumbs(true);">Hide Thumbs</a>
<a onclick="objctlDoc.HideThumbs(false);">Show Thumbs</a>

ctlDoc_splitter is not a Doconut property. Apparently, it is an id found in your HTML code, like the example id ("#div_ctlDoc") that I gave you in the previous answers.

If you have any other questions about the document viewer, feel free to ask!

Thank you so much for your support. I’ve successfully addressed the issue related to the ‘showThumb’ attribute.

1 Like