Free Support Forum -

DocImage.axd loading

I’m having a problem getting the system to run our our sandbox server. Everything runs fine on my local development machine. the web.config files are identical and has the handler in it.

  <add name="AjaxFileUploadHandler" verb="*" path="AjaxFileUploadHandler.axd" type="AjaxControlToolkit.AjaxFileUploadHandler, AjaxControlToolkit" preCondition="integratedMode" />
  <add name="DocImage" verb="GET,POST" path="DocImage.axd" type="DotnetDaddy.DocumentViewer.DocImageHandler, DocumentViewer" />

following the instructions outlined in the DocImage-Handler.pdf file, on the development machine, it shows as registered. image.png (8.6 KB)

When the project is published (in debug mode) to the server, I get the following error.
image.png (44.9 KB)

I have also tried various options with the BasePath but I think that really won’t be part of the solution until it is shown as being registered?

(.net webforms, IIS ver 10.0.17763.1 on Win Server 2019)



Just for the sake of testing, if you deploy the Net Core solution sample from the demos. Does this work?

I created a new site on the server and was able to publish the Webforms version and the viewer works. (We are not using net core)

I’m speculating that because my viewer is buried in a user control, that could be causing problems? I also see in the popup message that the path for the handler doesn’t look correct? image.png (7.3 KB)

I am going to program the viewer to be on a stand-alone page to see what the results will be. Helpfully you have some more suggestions.

As a reminder, the system works perfectly fine on my local dev machine.

UPDATE: Found the problem. You have to have the Application Pool set to Integrated, not classic.


I am happy the issue was solved. I will take notes of this and put on my suggestions when a similar issue arises.

Having the Application pool in Integrated mode solved it.